Major internet outage at North Pitt, Wellcome, and Bethel
Incident Report for Pitt County Schools
Resolved
Around 12.30 this morning teams repaired the damage and the schools are back up.
Posted Nov 20, 2024 - 08:45 EST
Monitoring
We are currently experiencing a service outage caused by a fiber cut in our network. Fiber optic cables are the critical lines that carry internet and communication services, and this cut has disrupted connectivity at North Pitt, Wellcome, and Bethel.

It will be some hours before there is a resolution but we will update things here as we know more.
Posted Nov 19, 2024 - 16:02 EST
This incident affected: Schools (Bethel, North Pitt High, Wellcome Middle).